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Das Pushen von Apps, Profilen, Richtlinien schlägt fehl (Status: Fehlgeschlagen oder Ausstehend)

Problem: Richtlinien, Profile oder Apps werden nicht zeitnah ausgerollt. In der Geräteübersicht (Verwaltung→ Geräte→ MDM-Status oder Verwaltung→ Geräte→ Apps) stehen die Apps oder Befehle auf dem Status Ausstehend oder Fehlgeschlagen.

MDM-Status der AppsMDM-Status der Richtlinien

Mögliche Ursachen

Der Status Ausstehend oder Fehlgeschlagen kann sehr viele Ursachen haben. Wir haben hier die häufigsten aufgeführt.

1. (MDM) Zertifikate/Konten sind abgelaufen/nicht funktionstüchtig.

2. Das Gerät ist beschäftigt.

3. Das Gerät kann dem Befehl nicht nachkommen, da der Inhalt fehlerhaft ist.

4. (Nur Apps) Lizenzprobleme beim App-Store-Konto-treten auf.

5. (Nur Apps) iOS-Apps sind nicht mehr im Store verfügbar.

Lösung

1. Öffnen Sie das Cortado Verwaltungsportal im Browser und überprüfen Sie die Zertifikatsinformationen auf Gültigkeit und Ablaufdatum. Ist das TLS-Zertifikat abgelaufen, erneuern Sie es.

  • Für Apple: Überprüfen Sie unter Verwaltung→ Einstellungen, ob das Apple Push Certificate noch gültig ist und verlängern Sie es ggf..
  • Für Android: Überprüfen Sie, ob unter Verwaltung→ Einstellungen→ Android Enterprise→ Konfigurieren alle Felder für Managed Google Play-Konten bzw. Google-Konten ausgefüllt sind.

2. Sind Geräte damit beschäftigt Updates, oder andere kritische Prozesse durchzuführen, können sie MDM-Befehle zurückstellen. I.d.R. kann es bis zu 10 Minuten dauern, bis ein MDM-Profil auf einem eingeschalteten, entsperrten Gerät ausgeführt wird, welches eine funktionierende Internetverbindung mit den notwendigen Portfreigaben hat. Sind diese Voraussetzungen alle erfüllt und dauert die Ausführung der Befehle trotzdem signifikant länger oder scheitert, prüfen Sie die anderen Punkte in dieser Liste.

3. Besonders bei Profilen kommt es immer wieder vor, dass sich Konfigurationsfehler einschleichen. Wird ein Gerät mit einer Konfiguration ausgestattet, welches einen Fehler aufweist (z.B. beim Verteilen von Zertifikaten, die nicht im richtigen Format/mit dem richtigen Inhalt ausgegeben werden) kommt es häufig zu einem Status Fehlgeschlagen. Wenn Sie einen solchen Status in der Konsole sehen, können Sie mit dem Mauszeiger über diesen fahren und das Gerätefeedback einsehen. Sollten Sie den Fehler nicht selbst beheben können, teilen Sie uns diesen über ein Support-Ticket mit.

4. Wenn Sie ein App-Store-Konto verwenden, der bei einem anderen MDM-System in Verwendung war und Sie Geräte einbinden möchten, die schon mit dem vorherigen MDM-System verbunden waren und von dort Apps bezogen haben, kommt es häufig zu Lizenz-Konflikten. Werden Lizenzen durch das MDM-System bei einem Löschvorgang nicht ordnungsgemäß von den Geräten entkoppelt, bekommen Sie den Status Fehlgeschlagen, der auf einen Lizenzierungsfehler verweist. Wir raten aktiv davon ab App-Store-Konten von einem anderen MDM-System zu übertragen. Um Lizenzierungsfehler zu vermeiden sollten Sie ein neues App-Store-Konto erstellen.

5. Wenn Sie den Status Fehlgeschlagen sehen, die darauf verweisen, dass eine App nicht mehr im App-Store verfügbar ist, können Sie auf dem Endgerät direkt im App-Store nach dieser App suchen. Finden Sie diese App nicht mehr, dann müssen Sie die App aus dem Verwaltungsportal entfernen. Die Auslieferung dieser App ist nicht mehr möglich.



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