Problem: Unter bestimmten Umständen (bei einem Update von älteren Versionen von Cortado Server (pre 9.0)) kann es vorkommen, dass im finalen Schritt des Updates, die Konfiguration des User Managements im Konfigurationsassistenten fehlschlägt.
Mögliche Ursachen
Die Hauptursache für einen Fehler in diesem Konfigurationsschritt sind Nutzer, die zwar noch in der Cortado Managementkonsole als Nutzer geführt werden, für die es keinen entsprechenden Account mehr im Active Directory gibt. Durch einen Doppelklick auf den fehlgeschlagenen Schritt erhalten Sie eine erweiterte Fehlermeldung. Wenn in dieser Meldung auf eine SID verwiesen wird, versuchen Sie den Fehler wie folgt selbst zu beheben. In allen anderen Fällen bitten wir Sie, die Fehlermeldung zu kopieren und ein Support-Ticket zu eröffnen.
Lösung
- Beenden Sie den Konfigurationsassistenten und starten Sie den Cortado-Log-Manager, den Sie hier für Ihre Version von Cortado Server herunterladen können. Dieser ist enthalten in der ZIP-Datei Tooling, falls nicht separat aufgeführt.
- Wählen Sie im Log-Manager auf der linken Seite CCSA (Pfeil im Bild). Darüber hinaus sind hier keine weiteren Einstellungen nötig.
- Gehen Sie anschließend folgendermaßen vor:
- Starten Sie den Konfigurationsassistent erneut und durchlaufen Sie den Konfigurationsprozess, bis Sie wieder auf den Fehler stoßen. Im generierten Log können Sie nach der referenzierten SID suchen und so den Nutzernamen ermitteln.
- Im User Management der Managementkonsole können Sie nun den betroffenen Nutzer finden und entfernen. Solange der CCSA noch nicht vollständig durchgelaufen ist, wird die Managementkonsole über ihren externen Namen nicht aufrufbar sein. Sie können die Managementkonsole aber auf dem Cortado-Server selbst, über https://localhost/fw öffnen.
- Wiederholen Sie diese Schritte, bis der Konfigurationsassistent ohne Fehler durchläuft.